Corvette problem – Service ASR

[Update: May 24, 2008]

A rebuilt ECM solved the problem.  While troubleshooting, I noticed that the ECM would not store the error codes.  This was an obvious sign of a faulty ECM, so I purchased a rebuilt ECM.  Problem solved, and rather cheaply also.  This is the benefit of having skills to troubleshoot your own “equipment.”  Also, it is VERY important to buy a rebuilt computer from a known reliable vendor.  It seems as though a lot of these ECM “rebuilders” are not shipping properly rebuilt units.

After my original post below, I parked the car for the winter (like I do every year, from November to March.)  Once I fired the car up this year, the problem was worse — the symptoms would occur on every drive.  This is when I noticed that the ECM would no longer store any error codes, and would only flash “1, 2”.  Hence, the problem was rather easy to diagnose once this behavior was consistent.

(Original Summary of problem, posted October 24, 2007)

I have a mint 1993 Corvette, garage-kept, purchased new by me in 1993, with only 10,000 miles, Automatic. It has developed a problem. While driving, it will occasionally flash the Check Engine light, and sometimes (simultaneously) flash the `Service ASR` light, flash “SYS” on the LCD dash.  When the problem occurs, “Service ASR” lights, the car may give a hard jerk, momentarily stall, etc. When this happens, it may be hard to keep the car running, and if it stalls, hard to restart. Let the vehicle sit a little while, maybe 20 minutes, and it will start and drive normally (like no problem ever happened). The problem has not occurred on very short trips (5 minute “trips-to-town”). Typically occurs after 12-15 minutes of driving.

Article Tags: |


Valid XHTML Valid CSS